読者です 読者をやめる 読者になる 読者になる

cocoapods のダウングレード

iOS Swift

iOS開発におけるライブラリ管理ツール、cocoapodsのベータ(1.0.0 beta 5)を試してみたが、Realm周りで問題が出るようなので、 安全策でダウングレードした。

  1. Xcodeのプロジェクトを丸ごとバックアップ
  2. pod deintegrate でプロジェクトから切り離し
  3. Podfile.lockを退避
  4. sudo gem uninstall cocoapods
    アンインストールするバージョンを聞いてくるので、ベータ版を指定。
  5. pod setup
  6. pod install

エラーメッセージをメモし忘れたのはちょっと失敗だったかな。

バージョン確認。

$ pod --version
0.39.0

しばらく様子見。